These forums are read-only and considered to be an archive. Please use the new GleamTech Community for future interaction and posts.

Weird URL after upgrade to 4.1 (.../eurl.axd/...)

We just upgraded to 4.1 and when we launch FileVista our address bar shows something like the following:

https://<hidden>/eurl.axd/c9cb49719a542c41b50446478481cb3e/

Things seem to work ok regardless of this, however when we try to reach the administration page, for example, we are taken to:

https://<hidden>/eurl.axd/c9cb49719a542c41b50446478481cb3e/administration.aspx

and this page can't be found, if I manually set the URL to:

https://<hidden>/administration.aspx

we can then get to the Administration page.  What's up with the weird URL's and how can we get rid of them?

Chris S 3/14/2011 7:09 AM
This is related to a new feature in ASP.NET 4.0 for supporting extensionless URLs on IIS 6.0.

Normally, you should never see the URLs ending with "eurl.axd/xxx".

Possible reasons:

1. (Not likely your case) After ASP.NET 4 has been enabled on IIS 6, ASP.NET 2.0 applications that run on IIS 6 might generate this error.

2. A conflicting 3rd party ISAPI filter (like a rewrite filter)

3. (Likely your case) A redirection you setup in IIS. For instance, redirecting non-www records on a website to another in the same pool.

Possible solutions:

1. Use the registry key to just turn this ASP.NET 4.0 feature off. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ASP.NET\4.0.30319.0 > DWORD EnableExtensionlessUrls to 0 , then restart IIS.

2. Install your ISAPI filter URL rewriter at the global level at a priority higher than aspnet_filter.dll or insert a rule in your rewriter to completely ignore URLs with eurl.axd in them. This might be as simple as
RewriteRule eurl\.axd -

References:
ASP.NET 2.0 Applications Might Generate HttpException Errors that Reference eurl.axd
How to Disable the ASP.NET v4.0 Extensionless URL feature on IIS 6.0
ASP.NET MVC eurl.axd errors
Cem Alacayir 3/14/2011 8:32 AM
We're redirecting everyone that visits it via HTTP to HTTPS.  Thanks to your response that was identified as the issue.  I'll either rewrite our redirect to see if that will fix things or disable it via the registry as you mentioned.

Thanks
Chris S 3/14/2011 9:18 AM
I ran into a similar issue with v4.0 ASP.Net extension less URL feature on II6 and found a solution through ISAPI Rewrite Module provider, the does not require turning it off.  Theissue and the solution as we experienced it is documented here http://www.vanadiumtech.com/OurBlog/post/2011/08/12/Cause-of-eurlaxd.aspx
Vanadiumtech 8/11/2011 2:54 PM