These forums are read-only and considered to be an archive. Please use the new Community for future interaction and posts.

Problem Retrieving Language File

I am getting the following error when trying to use the control on any page...

"There was a problem retrieving the language file."

"Method Not Allowed. Error 405"

Any ideas? The language file is there and "Everyone" has access to it. No one has deny permissions.

Jake 1/22/2008 8:54 AM
After setting the debug attribute to true, I noticed it isn't failing trying to find the file, but rather when it is trying to send a post to filevista.asmx. I confirmed in IIS that asmx is mapped to the correct dll and post is included in the allowed verbs. I also verified the following is correct in my web.config...

  <add name="HttpPost"/>

Any ideas on what to try next? Thanks!

Jake 1/22/2008 9:01 AM
Run the following the command to re-register the ASP.NET mappings:
<WindowsDir>\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis -i

Let me know.
Cem Alacayir 1/22/2008 9:37 AM
If you are on IIS 6.0 or later, you can also try "aspnet_regiis -enable" if it is still not fixed.
Cem Alacayir 1/22/2008 9:43 AM
Got it figured out. It turns out the problem was with our URL Rewriter. I'm not sure why, but even if the URL to a web service is allowed, the rewriter screws up the post request. So I modified the global.asax to not execute the rewriter if the url being requested is FileVistaControl/filevista.asmx and everything seems to work. I hope this helps anyone else who runs into this issue.

Jake 1/22/2008 9:59 AM