These forums are read-only and considered to be an archive. Please use the new Community for future interaction and posts.

Upload Error #2038


one of our customers get's an error #2038 when trying to upload files.

what's that about?

Chris Adelt 7/4/2008 4:11 AM
this only seems to happen with mozilla Firefox...

IE7 seems to work.
Anything I can do about this?
Chris 7/4/2008 4:56 AM
Hi Chris,
We have recently fixed an upload problem in v3.2.2 so please update your version. The problem occured in Flash upload mode when uploading more than one file at once. The error was occuring when one of the files took long time to finish, causing a timeout and stopping the overall upload with an error message. 
Cem Alacayir 7/7/2008 4:35 PM
I currently have the latest version v3.2.2 and getting the same #2038 error in both mozilla 3.0 and ie7, it started after an upload failed in ie7 and even after restarting IIS still getting the same error, any Ideas other then reloading the whole folder
John Gagnon 7/9/2008 10:02 PM
Any news on this? Our customer is waiting for the update anxiously.

I haven't tried the update to 3.2.2 yet and if it doesn't help I'd wait for any fixes as well. I do need the source code version as well please if anything is fixed in it.
Chris Adelt 7/10/2008 4:55 AM
Please either delete all the failed files and try to upload again or check if "Edit" permission for the folder is set in FileVista, this permission allows the overwriting of files during upload. If none of them works, please see below.

I would first recommend you to update to 3.2.2 so that we can narrow the reasons. I have sent you the details via email.

Flash error #2038 is a generic error and there may be several reasons. However you can force Browser upload mode instead of Flash upload mode by adding this line: 

<add key="UploadMethod" value="Browser" /> 

to FileVista\App_Data\FileVista.config. 

This way, we can understand if the error is specific to Flash upload mode and also you may receive a more detailed error message in Browser upload mode.

Let me know the results.
Cem Alacayir 7/10/2008 5:17 PM
The error is definitely related to flash, last night I disabled the flash plugin and was able to upload a 500MB file without any problem.  But as soon as the flash is turned back on I can't even upload a 4MB file.  I've already reinstalled flash but it made no difference, I'll try to add the key tonight in the config file but in theory disabling the flash plugin should of done the same thing then the key will do.  I'll also recreate the application in a different folder in trial mode and see if it does the same thing to eliminate the possibility of a corrupted application.  
John Gagnon 7/10/2008 6:27 PM
I updated to 3.2.2 and still get the same Error.
Even with <add key="UploadMethod" value="Browser" /> added to filevista.config it didn't change anything. It looks as if it still uses the flash module and it still gives the #2038 error. But only with Firefox. And only at some machines. It's kind of hard to find the error because I personally can log into the system with firefox and it does work fine.
On the other hand there is our customer trying to use it with FF and can't upload anything. The difficulty is, that I can't even run tests without his help, which makes it hard to work with.
Chris Adelt 7/14/2008 5:05 AM
After adding the key to FileVista.config, you need to refresh the main FileVista page, then re-open the Upload dialog. If you are really in Browser upload mode, you should see another error and not the error #2038.

Also after an upload error occurs, please go to the administration page of FileVista and see Events section. Open the related "Failure" event to see more information on the upload error. Please make sure that you have enabled logging events for upload in application settings dialog before this test.
Cem Alacayir 7/16/2008 6:17 PM
OK, sorry guys it took so long to reply on this one but been very busy. I ended up reinstalling filevista several times to find out what the problem was with 3.2.2.  Anytime somebody upload something that takes above about 2 hours, even if the file is not that big but just a slow connection, the fault will reappear on both IE and FF for everybody afterwards.  If somebody close the window or loose a connection while uploading while using.... FF only....,  the problem reapears. FYI it only take about 1.5 hour with FF 3.0 to get the same error.
But if I have them, or myself (first hand experience), disable flash, it works just fine just fine w/out having to reinstall filevista.....any ideas, I need some help here.  Wish  I could help further but after looking at all the code at my disposition,  I would need the entire source to figure that one out.   BTW I also tried on a fresh copy of Win2003 enterprise and same problem....So its not my setup with IIS
John Gagnon 7/16/2008 7:56 PM
I'm totally lost.

I just set up a second web and copied the complete folder of filevista in it. So it's the exact same system. And it works.

The only difference I can make out is that it is not using https.

The live system which does use a https connection seems to be problematic.

Could that be the problem?
Chris Adelt 7/17/2008 4:35 AM
Hi guys - 
   I'm running the trial right now, to determine if FV is right for me.

Unfortunately, I'm running into this problem.  I'm trying to upload a 239Mb file, from a remote location.  I've also tried it with a 7Mb file with the same results.

If I attempt to change the UploadMethod to Browser, I start getting "Connection closed between browser and server." error.

Please let me know if there's any way I can assist in t/s.
Jay Erskine 7/17/2008 11:11 AM
I'm also getting error 1309 in my event log.
Jay Erskine 7/17/2008 11:13 AM
Thank you all for the feedback, it's very appreciated. We have used this information and made the Flash upload mode more robust in v3.2.4.

We increased the execution timeout to 1 day in upload module so you will be able to upload longer than 2 hours. Also session will be kept alive during uploading in flash upload mode so timeout related problems should completely disappear.

I hope v3.2.4 solves your problem too but it may be related to Https because flash upload fails with https under some conditions as discussed Browser prompts for credentials on upload and freezes. By the way, detailed error messages will be displayed in flash mode instead of the generic #2038 error in flash mode from now on.

Please uninstall the previous version and install v3.2.4 and let me know if you are still getting the same error.

Cem Alacayir 7/18/2008 9:12 AM
Now I'm getting "Unable to retrieve XML data"

Internal server Error 500
Jay Erskine 7/18/2008 12:22 PM
Here's something weird.  This error doesn't occur in IE 7, but does in Firefox 3
Jay Erskine 7/18/2008 12:32 PM
Clearing cache resolved the problem.
Jay Erskine 7/18/2008 12:33 PM
This is still bombing out when I attempt to upload a 239Mb file
Jay Erskine 7/18/2008 12:39 PM
Thought I would bump this.
Jay Erskine 7/22/2008 6:44 AM
I haven't received 3.2.4 yet. I do need the source code version please.

I'll let you know if that fixes the problem.

By the way: Another customer ran into the same #2038 problem now. It seems it only happens after a while but doesn't go away after that. And still only with FF. IE7 and Safari work fine.
Chris Adelt 7/23/2008 1:17 AM
I guess you haven't received my email on July 20th:

1. What's the IIS version and if it's IIS7, is the mode integrated or classic for FileVista folder? Changing it to classic mode may help.

2. Are you running any other ISAPI modules or HttpModules or anything like UrlScan? 

3. If you are on IIS7, it  has a built-in request scanning which imposes an upload file cap which defaults to 30MB. It gets in the way if you're looking to upload files larger than 30MB. You can increase this limit to 2GB from the commandline:

appcmd set config "My Site/MyApp" -section:requestFiltering -requestLimits.maxAllowedContentLength:2140708864 -commitpath:apphost

I have sent you the source code package of v3.2.4.
Cem Alacayir 7/24/2008 9:22 AM

ok I updated to 3.2.4. Now it doesn't come up with the #2038 Error so far (and I hope it will never ever again) but something else popped up:

When uploading multiple files it sometimes hangs with the Error: "Ein Fehler ist aufgetreten" which is "An Error has occured" in English.
When this happens you won't be able to upload the same file again because it will always show the same error. When you log out and back in it sometimes works again with single file upload. The Browser was Safari or FireFox - same behaviour.
I don't really know if it happens just to certain files or not. There was one file that seemed to have more problems than others. It was about 60mb but some files with 120mb or more didn't have any problems at all.
I tried browser upload mode but this is sooooo slow. I get 7-8MByte/sec with flash upload, and just 500-700kb/sec with browser upload mode. Is that a proxy issue? Or again something about https?
I don't know if I have any more valuable information about this...
Chris Adelt 7/29/2008 12:56 AM
If you are using FileVista in AD Integration mode/Windows authentication, you will not be able to use Flash upload mode, you will need to use Browser upload mode. This is because Shockwave Flash Plugin does not properly handle HTTP Authentication. You will get the HTTP Authentication prompt but most often it won't authenticate.

Maybe you should provide me a URL to your installation so that I can see if any other thing may prevent Flash upload from functioning properly.
Cem Alacayir 7/29/2008 1:48 PM
I have sent you the url and a standard user login at your support email adress.
Chris Adelt 7/30/2008 12:08 AM
Just for your information:

We installed an officially signed certificate today and all problems vanished.
We used to use a self-signed certificate for the filevista system which seemed to cause all the trouble with uploads and the flash-plugin.
After the update to 3.2.4 the flash error was gone but it started to show "an error has occured" when stating to upload.

So I guess it's finally solved.
Chris Adelt 8/20/2008 1:37 AM
It happened again. "An error has occured" as soon as one has chosen a file to upload and presses the "upload" button.
Only with Firefox again. It works with IE.
We are using officially signed certificates now...
Chris Adelt 8/28/2008 4:48 AM
Did you try to add your certificate to certificate store in Firefox?
Cem Alacayir 9/1/2008 1:40 PM
Here is the solution: Change the security access permissions on the file. I mean right click -> Security -> select the user -> Grant full control.  After doing the setup you try uploading the again. This time it will work. 
Aswani kumar Konduru 8/17/2011 8:06 PM
I uploaded the latest version of Flash and it resolved the issue.....SIMPLE.
Ted 3/7/2012 11:27 AM
we are also struggling with same issue and could not able to upload a file over CMA

plz any advise to fix
Yashpal 11/8/2012 10:27 PM
Just got this error msg after installing the latest patch.
Paul 4/26/2013 8:48 AM