These forums are read-only and considered to be an archive. Please use the new Community for future interaction and posts.

Error 1 - Operation not permitted

Many of our users are experiencing this problem when Download as a zip. My guess is the zip file is being corrupted? Or is some setting I need to setup?

Most of the files can be fairly large 10-25mb each and anywhere from 1 file up to 1000. Even smaller batches of 1-2 files are throwing this error to some users.

"Error 1 - Operation not permitted".

If you have any info to help, I would appreciate it! Let me know if there is anything you need from me. Thanks!
Dustin B. 6/28/2012 8:31 AM
I should note that the error is being thrown when they have downloaded the file completely and are trying to unzip it.
Dustin B. 6/28/2012 8:31 AM
I guess you are getting this error on Mac only. Please try to extract the same downloaded zip file on a Windows system to see if it's actually corrupted. Actually in v3.1, we had improved compatibility with Mac Archive Utility which seems to be picky about zip formats. We had tested on Snow Leopard and Lion and we hadn't noticed any problems. Let me know.
Cem Alacayir 6/28/2012 12:24 PM
Yes, our clientele is almost 90% MAC based which most errors have been coming from. I don't think they would be keen to switching to a PC though. :)

Is there something we can do to improve the compatibility?
Dustin B. 6/28/2012 12:31 PM
No you misunderstood, Mac compatibility is important for us too and we already fixed the zip issues back in v3.1. Current version is 3.2. I only said you should test the same zip file on Windows (if available) to find out if the zip was corrupted during transmission or if it was only a problem with Mac Archive Utility. I didn't mean switch to Windows :)

As I said, with our testings the zip files are extracted without problem on Max OSX Snow Leopard and Lion. So you need to provide more information like the Mac OSX version and the results with other unzippers like Stuff-it on Mac. For instance, I bet you will be able the extract the same zip file from Terminal on Mac. Archive Utility is buggy especially on older Mac OSX versions.
Cem Alacayir 6/28/2012 1:10 PM
Hi Cem,

I hate to say it, but very few of our customers can unzip the files after downloading. The downloads are completing fully. They are all on Mac OSX. All different versions, both SL and Lion. Even if the files are only around 100mb. It's common the zips can reach into the 700+mb range as well. This was a huge selling point for us as zipping up files was taking a huge part of our workflow.

If you have access to mac, please do some more testing on larger file sizes. There may be a problem with the sizes?

Please let me know any information you find. I need to keep my customers happy and the complaints are rolling in! Appreciate any help!
Dustin B. 7/20/2012 8:34 AM
Hi Dustin,

Did you get the issue resolved with Cem?
Rob 7/22/2012 5:10 PM
Hi Rob,

Nothing yet.
Dustin B. 7/31/2012 8:49 AM
I will the response time was a little faster.  The software is pretty awesome.
Rob 8/3/2012 2:38 PM
Correction :-)
I WISH the response time was a little faster. :-). The software is pretty awesome.
Rob 8/3/2012 2:38 PM
Hi Rob,
Are you experiencing the exact same issue (Error 1 - Operation not permitted)?

Please send a sample zip file preferably of small size to the support email.
If your Mac users use Safari and the zip files are deleted after being automatically extracted, then tell them to uncheck this setting:

Safari > Preferences > General > Open "safe" files after downloading.

This way they can send you the original zip file resulted with "Download As Zip" action.

I couldn't replicate the error myself so I will examine your zip file to see if it's corrupted. I suspect something like an ASP.NET module in your application may be interfering during streaming the zip. For instance, writing junk (like some HTML or error message) to the response stream under the hood may be corrupting the zip. Even if it turns out the zip is not corrupted, I will examine the zip structure (like non-ascii names, folder structure etc.) to find out what may be causing the problem and apply the fix if necessary.
Cem Alacayir 8/4/2012 5:50 PM
I just tested this and the zip feature seems to be working fine for my clients on their Macs.  Dustin, send Cem that test file when you have a chance!
Rob 8/4/2012 7:27 PM

I experienced the same error just now. 

I solved the problem with an app called 'The Unarchiver' - the app asked me, if I want to allow the app to extract despite the 'sandbox' settings of MacOS. Once I confirmed the file got extracted correctly.

This means there is a setting somewhere in MacOS which prohibits the extraction.

Alex 1/23/2013 11:05 AM