These forums are read-only and considered to be an archive. Please use the new Community for future interaction and posts.

Installation : missing some details?


the demo project works great when running in VS2010, but the implementation of the component in my live environment gives me some trouble. I can only see the URL, which indicates (according to another post) that it cannot find CSS and JS files (which are not even in the setup?). Can you please check if I have taken the correct steps, and correct me where I went wrong?

1) Environment : IIS Express on Windows 7 workstation
2) Website root location (directory with things like WEB.CONFIG, the BIN folder and the DEFAULT page) : D:\INETPUB\MYWEBSITE\WEBSITE
3) I've copied the file GleamTech.FileUltimate.dll (version to the BIN folder
4) I've created a directory FileUltimate in the root directory (so D:\INETPUB\MYWEBSITE\WEBSITE\FILEULTIMATE) (why is this?)
5) I've placed the tag in the ASCX file (<%@ Register TagPrefix="GleamTech" Assembly="GleamTech.FileUltimate" Namespace="GleamTech.FileUltimate" %>)
6) I've added the control to the same ASCX page (<GleamTech:FileManager ID="fileManager" runat="server" />)
7) As a precaution I've copied the whole App_GlobalRescources directory (including all subdirectories) to the root directory (so D:\INETPUB\MYWEBSITE\WEBSITE\APP_GLOBALRESOURCES)

When I run my application and go to the page, I only see the URL. Also, when viewing the code, I see the three lines in the HEAD section but clicking on them gives an error.

Can you please tell me what I am missing? Thanx in advance.

Best regards,
Hessel 6/20/2013 6:26 AM
You only need to deploy GleamTech.FileUltimate.dll. Css and Js files are already embedded into the dll.
So do not create a subdirectory named FileUltimate and do not copy the whole App_GlobalRescources directory.

Your problem is that resource URLs are not working due to your IIS configuration. 
I can help you better if you answer these questions:

What are the three exact URLs you see in the HEAD section?
What is the exact error you get when you click them? HTTP 404 or 500?
Cem Alacayir 6/20/2013 6:54 AM
Hi Cem,

thanks for answering. The three lines are :

<link href="/resource.ashx/635047462760000000/fileultimateresourcestore/combined.css" rel="stylesheet">
<script src="/resource.ashx/635047462760000000/fileultimateresourcestore/combined.js"></script>
<script src="/resource.ashx/635047462760000000/fileultimateresourcestore/language-nl.js" charset="utf-8"></script>

When clicking on any of these lines I get a error 500.  Hopes this helps.

Best regards,
Hessel 6/20/2013 7:25 AM
Additional information : when I run the page on e real (non IIS express) webserver, I again see the three lines but when I click on them I do not get an error message, but an empty file (no code). Is this of any help?
Hessel 6/24/2013 1:18 AM
I thought this should be about IIS Express only but now you say it does not work on IIS too?

What's the detailed error message for Http 500 error on IIS Express?

Cem Alacayir 6/24/2013 2:16 AM
Hi Cem,

as requested the output in the CONSOLE screen :

GET https://nnek2012.local/resource.ashx/635047462760000000/fileultimateresourcestore/combined.js 500 (Internal Server Error) Gegevens.aspx:9
GET https://nnek2012.local/resource.ashx/635047462760000000/fileultimateresourcestore/language-nl.js 500 (Internal Server Error) Gegevens.aspx:9
GET https://nnek2012.local/resource.ashx/635047462760000000/fileultimateresourcestore/combined.css 500 (Internal Server Error) Gegevens.aspx:9
Uncaught ReferenceError: GleamTech is not defined Gegevens.aspx:407
(anonymous function) Gegevens.aspx:407

Looks like it's not registering the component correctly, even though I've put the following line on top of the ascx file :

<%@ Register TagPrefix="GleamTech" Assembly="GleamTech.FileUltimate" Namespace="GleamTech.FileUltimate" %> 
Hessel 6/24/2013 5:30 AM
It turned out Hessel was using SiteCore CMS which took over FileUltimate requests and caused a Http 500 error. I recommended him to make SiteCore ignore FileUltimate related handler urls (resource.ashx, filemanager.ashx, fileuploader.ashx). For reference, please see this article.

Cem Alacayir 6/24/2013 6:18 AM
adding the three ASHX files to the IgnoreUrlPrefixes tag in the WEB.CONFIG indeed did the trick. I can confirm that it works now. Thanks for the support!!

Hessel 6/24/2013 6:23 AM